What are the system requirements for LANDSCAPE?

All you need to use LANDSCAPE is a modern web browser and an internet connection. LANDSCAPE no longer supports any version of Internet Explorer. You may use Google Chrome, Firefox, Microsoft Edge or Safari. 

Javascript and cookies must be enabled in the browser. These are the default settings on most browsers.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk